206
云计算
负载均衡
产品简介
产品价格
快速入门
用户指南
实践操作
常见问题
购买指南
云服务器
产品简介
计费规则
购买指导
控制台使用指南
常见问题
云数据库
产品简介
计费规则
购买指导
快速入门
连接实例
控制台使用指南
对象存储
产品简介
控制台使用指南
程序员百科
Python
Windows实例系统更新失败, 提示“0x80070422(服务无法启动或运行)”错误怎么办?

产品推荐:

1、安全稳定的云服务器租用,2核/2G/5M仅37元,点击抢购>>>

2、高防物理服务器20核/16G/50M/500G防御仅350元,点击抢购>>>

3、百度智能建站(五合一网站)仅880元/年,点击抢购>>> 模板建站(PC+手机站)仅480元/年,点击抢购>>>

4、阿里云服务器2核2G3M仅99元/年、2核4G5M仅199元/年,新老同享,点击抢购>>> 

5、腾讯云服务器2核2G4M仅99元/年、新老同享,点击抢购>>>   


点击这里点击这里进入阿里云ECS官方页面,立即免费体验云服务器ECS>>>

本文介绍Windows实例系统更新失败,提示“0x80070422(服务无法启动或运行)”错误的解决方案。

问题现象

在Windows系统的ECS实例中,出现Windows系统无法获取更新或安装更新失败的问题,并提示“0x80070422(服务无法启动或运行)”错误。如下图所示:

image

问题原因

导致该问题的可能原因包括但不限于以下几点:

  • Windows防火墙服务(mpssvc)未运行。您可以通过修改注册表并启动防火墙服务来解决该问题。具体操作,请参见Windows系统的ECS实例更新系统时,一直卡在0%该如何处理?。

  • Windows系统更新依赖的服务无法启动,分为以下几种情况:

    • 服务被禁用。您可以重新启用更新依赖的服务来解决该问题。具体操作,请参见方案一:通过PowerShell或修改注册表启用服务。

    • 服务所对应的二进制文件不存在或无法加载。您可以修复对应的二进制文件来解决该问题。具体操作,请参见方案二:使用SFC工具修复二进制文件。

解决方案

方案一:通过PowerShell或修改注册表启用服务

  1. 远程连接Windows实例。

    具体操作,请参见通过密码或密钥认证登录Windows实例。

  2. 选择以下任一方式,启用被禁用的服务。

    执行PowerShell脚本
    手动修改注册表
    1. 打开CMD命令提示行。

      1. 右键单击Dingtalk_20210510142550.jpg图标,然后单击运行win2016运行

      2. 运行对话框中输入cmdwin2016

      3. 单击确定

        进入CMD命令提示行。win2016cmd命令提示行

    2. 执行以下命令,进入PowerShell模式。

       
      powershell
    3. 执行如下命令,以管理员身份运行Windows PowerShell脚本。

       
      Set-Service -Name <ServiceName> -StartType AutomaticStart-Service -Name <ServiceName>
      说明

      请您根据实例诊断报告信息,将上述脚本内容中的<ServiceName>修改为实际被禁用的服务名称。具体的诊断项以页面显示为准。更多信息,请参见诊断实例的健康状态。

      BITS服务为例,若系统返回类似如下信息,则表示启动BITS服务失败。

      image

    4. (可选)如果脚本无法启动目标服务,则需要重启实例使配置生效。

      具体操作,请参见重启实例。

      说明

      部分系统服务必须重启实例,请以实际操作环境为准。

  3. 重新更新Windows系统,如果可以正常更新或安装,说明问题已解决。

方案二:使用SFC工具修复二进制文件

  1. 远程连接Windows实例。

    具体操作,请参见通过密码或密钥认证登录Windows实例。

  2. 打开CMD命令提示行。

    1. 右键单击Dingtalk_20210510142550.jpg图标,然后单击运行win2016运行

    2. 运行对话框中输入cmdwin2016

    3. 单击确定

      进入CMD命令提示行。win2016cmd命令提示行

  3. 执行以下命令,检测所有系统文件的完整性并执行修复动作。

     
    sfc /scannow
  4. 重新更新Windows系统,如果可以正常更新或安装,说明问题已解决。


这条帮助是否解决了您的问题? 已解决 未解决

提交成功!非常感谢您的反馈,我们会继续努力做到更好! 很抱歉未能解决您的疑问。我们已收到您的反馈意见,同时会及时作出反馈处理!