206
云计算
负载均衡
产品简介
产品价格
快速入门
用户指南
实践操作
常见问题
购买指南
云服务器
产品简介
计费规则
购买指导
控制台使用指南
常见问题
云数据库
产品简介
计费规则
购买指导
快速入门
连接实例
控制台使用指南
对象存储
产品简介
控制台使用指南
程序员百科
Python
Windows实例更新或安装角色时出现“0x80073712(组件存储已损坏)”错误,如何处理?

产品推荐:

1、安全稳定的云服务器租用,2核/2G/5M仅37元,点击抢购>>>

2、高防物理服务器20核/16G/50M/500G防御仅350元,点击抢购>>>

3、百度智能建站(五合一网站)仅880元/年,点击抢购>>> 模板建站(PC+手机站)仅480元/年,点击抢购>>>

4、阿里云服务器2核2G3M仅99元/年、2核4G5M仅199元/年,新老同享,点击抢购>>> 

5、腾讯云服务器2核2G4M仅99元/年、新老同享,点击抢购>>>   


点击这里点击这里进入阿里云ECS官方页面,立即免费体验云服务器ECS>>>

本文介绍Windows实例更新或安装角色时出现“0x80073712(组件存储已损坏)”错误的问题原因和解决方案。

问题描述

在Windows Server 2012系统的实例中安装更新的时候,出现“0x80073712”错误。使用服务管理器安装新角色的时候,如下图所示,出现“0x80073712(组件存储已损坏)”错误。

问题原因

该错误一般是由于Windows组件存储不一致问题导致的。

解决方案

可以尝试通过如下方式排查分析。

  1. 远程连接Windows实例。

    具体操作,请参见通过密码或密钥认证登录Windows实例。

  2. 打开CMD命令行窗口。

  3. 在CMD命令行中输入以下命令,且在每项命令后按Enter键。

     
    DISM.exe /Online /Cleanup-image /ScanhealthDISM.exe /Online /Cleanup-image /Restorehealth

    说明

    根据系统环境不同,该操作可能会比较耗时(10分钟之内)。

  4. 再次运行Windows更新或安装所需的相关角色服务。

  5. 如果仍然失败,请参考Windows Update补丁更新失败的处理进行处理。


这条帮助是否解决了您的问题? 已解决 未解决

提交成功!非常感谢您的反馈,我们会继续努力做到更好! 很抱歉未能解决您的疑问。我们已收到您的反馈意见,同时会及时作出反馈处理!