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安装AD域控制器时,提示“找不到网络路径”错误怎么办?

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问题现象

在Windows系统的ECS实例中安装AD域控制器时,提示“找不到网络路径”错误。

问题原因

可能有以下几点原因导致:

  • AD域控制器和客户端的TCP/IP NetBIOS HelperRemote Registry服务没有启动。

  • 客户端与AD与控制器的DNS配置错误。

  • 客户端和AD域控制器的SID造成冲突。

  • 防火墙及安全软件进行了拦截。

解决方案

请参考以下操作进行排查。

  • 启动TCP/IP NetBIOS Helper和Remote Registry服务

    请参考解决方案分别启动AD域控制器和客户端的TCP/IP NetBIOS Helper和Remote Registry服务。

  • 修改客户端DNS配置

    请参考解决方案修改客户端DNS配置。

  • 修改客户端SID

    请参考以下操作修改客户端SID。

    1. 远程连接Windows实例。

      具体操作,请参见通过密码或密钥认证登录Windows实例。

    2. 下载修改客户端SID的PowerShell脚本。

      • 下载地址:AutoSysprep.ps1

      • 脚本来源:阿里云官方

    3. 打开CMD,输入powerShell切换至Windows PowerShell界面。

      说明

      如果您的实例操作系统是64位,则不能使用32位的PowerShell(即Windows PowerShell (x86)),否则会报错。

    4. 切换至脚本存储的路径,执行如下命令,查看脚本工具说明。

       
      .\AutoSysprep.ps1 -help
    5. 执行如下命令,重新初始化服务器的SID。

       
      .\AutoSysprep.ps1 -ReserveHostname -ReserveNetwork -SkipRearm -PostAction "reboot"

      初始化完成后,会重启实例,您需要注意以下事项。

      • IP地址的获取方式会从DHCP变成固定IP地址,请确保该固定IP地址和开始设置前ECS实例的IP地址一致。您也可以将获取方式改回DHCP,以自动获取控制台中为ECS实例分配的主私有IP地址。

        说明

        请不要在控制台修改ECS实例的主私有IP地址,否则IP地址变化会导致访问异常。

        重新改成DHCP
      • 初始化SID后,云服务器防火墙的配置被修改成微软的默认配置,导致云服务器无法Ping通。您需要关闭防火墙来宾或公用网络,或者放行需要开放的端口。下图表示防火墙来宾或公用网络的状态是已连接。来宾或公用网络

    6. 打开控制面板修改防火墙设置,关闭来宾或公用网络防火墙。

      关闭来宾或公用网络防火墙

      关闭后,可以Ping通服务器。PING通服务器示意图

  • 允许客户端通过防火墙等安全软件

    请参考Windows Server系统的ECS实例防火墙策略的配置方法允许客户端通过。


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