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天翼云服务器常见问题-弹性云主机配置的邮件无法正常发送怎么办?

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本文为您介绍“弹性云主机配置的邮件无法正常发送”时的处理办法。

问题描述

弹性云主机配置的邮件无法正常发送。

问题原因以及处理方法

使用邮件客户端收发邮件

问题原因:

在使用邮件客户端收发邮件时,邮件收发使用不同的协议

  • 发件协议:

使用SMTPS协议,其端口号为465。或使用SMTP协议,其端口号为25。

Tips :优先推荐使用465端口,465端口是为SMTP SSL(SMTP-over-SSL)协议服务开放的,这是SMTP协议基于SSL安全协议之上的一种变种协议,它继承了SSL安全协议的非对称加密的高度安全可靠性,可防止邮件泄露。

  • 收件协议:

使用POP3协议,其端口号为110。

处理方法:

添加“出方向”(协议为“TCP”,端口为“25”或“465”)和“入方向(协议为“TCP”,端口为“110”)的规则。

操作步骤:

  1. 在云主机详情页面找到对应的安全组,进入安全组列表页面,如图1所示;
    图1 安全组列表页

    image.png

  2. 在安全组页面,单机对应的安全组,点击添加规则,进行规则添加页面,如图2所示;
    图2 添加规则入口

    image.png

  3. 添加“出方向”(协议为“TCP”,端口为“25”或“465”)的规则,如图3所示;
    图3 “出方向”规则添加

    image.png

  4. 添加“入方向”(协议为“TCP”, 端口为“110”)的规则,如图4所示。
    图4 “入方向”规则添加

    image.png

使用浏览器发送邮件

问题原因:

在使用浏览器登录邮箱时直接使用 HTTP 协议,其端口号默认为 80,邮件主机之间还是使用邮件发送协议:SMTP 协议。

处理方法:

需要开放TCP出方向端口为80。

操作步骤:

  1. 在云主机详情页面找到对应的安全组,进入安全组列表页面,如图5所示。
    图5 安全组列表页面

    image.png

  2. 在安全组页面,单机对应的安全组,点击添加规则,进行规则添加页面,如图6所示。
    图6 添加规则入口

    image.png

  3. 规则选择“出方向”、“TCP”协议、端口80,点击确定完成规则添加,如图7所示。
    图7 添加规则页面

    image.png


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