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远程桌面服务认证到期导致远程登录Windows实例失败如何解决?


远程桌面服务认证到期导致远程登录Windows实例失败如何解决?

本文介绍因远程桌面服务认证到期,导致远程登录Windows实例失败的解决办法。

问题现象

在远程登录Windows实例时,出现缺少远程桌面授权服务器许可证的提示,远程登录Windows实例失败。以您在本地使用Windows操作系统自带的远程桌面连接工具MSTSC远程登录Windows实例为例,提示如下。
说明
该场景下,仅支持使用VNC方式远程登录Windows实例。
缺少许可证

问题原因

因Windows操作系统中安装的远程桌面服务认证到期后,导致您远程登录Windows实例失败。远程桌面服务认证到期的原因有如下几种:

  • 在Windows操作系统内安装了远程桌面会话主机角色,此功能免费试用120天,之后需要进行付费。如果没有付费,该服务到期后会导致终端远程登录Windows实例失败。
  • 正常情况下,Windows服务器默认提供两个用户的免费远程桌面管理授权。如果有更高的连接需求,则需要配置远程桌面会话主机服务器角色,同时购买和配置相应的授权后,才可以使用更多的远程桌面管理并发。
  • 在配置远程桌面会话主机角色后,会同时取消默认两个用户的免费连接授权。在没有正确配置相关授权的时候,远程登录Windows实例将会无法连接。

解决方案

重要
  • 如果您对实例或数据有修改、变更等风险操作,务必注意实例的容灾、容错能力,确保数据安全。建议您提前创建快照,快照相关信息,请参见快照概述。
  • 如果您在阿里云平台授权或者提交过登录账号、密码等安全信息,建议您及时修改安全信息。
  1. 使用VNC连接Windows实例。
    具体操作,请参见通过密码认证登录Windows实例。
  2. 在Windows操作系统上,删除远程桌面服务。
    说明
    以下操作步骤以Windows Server 2016为例,实际操作系统以您实际的Windows实例为准。
    1. 在Windows操作系统左下角,选择开始 > 服务器管理器
    2. 服务器管理器页面右上角,选择管理 > 删除角色和功能
    3. 选择目标服务器页面,选择Windows实例,然后单击下一页
    4. 服务器角色页面,角色列表中选中远程桌面服务,然后单击下一页
      删除远程桌面服务
    5. 删除功能页面,选中远程桌面服务
    6. 在弹出的对话框,选中删除管理工具(如果适用)并单击删除功能,然后单击下一页
      删除远程连接功能
    7. 确认删除所选内容页面,单击删除
    8. 根据删除进度页面提示,重启Windows实例。
      具体操作,请参见重启实例。删除进度
  3. 使用VNC连接Windows实例。
    具体操作,请参见通过密码认证登录Windows实例。
  4. 在Windows操作系统上,查看远程桌面服务删除进度。
    1. 在Windows操作系统左下角,选择开始 > 服务器管理器
    2. 服务器管理器页面右上角,选择通知 > 任务详细信息
      如果在任务详细信息和通知页面无任务信息或显示出现远程桌面服务删除任务完成的通知,则表示远程桌面服务删除成功。
  5. 重新使用MSTSC远程登录Windows实例。
    您也可以使用其他方式远程登录Windows实例,具体操作,请参见 连接方式概述 。
    1. 选择以下任一方式启动远程桌面连接(MSTSC):
      • 使用Win+R组合键打开运行对话框,输入mstsc,然后单击确定mstsc
      • 单击开始图标,在搜索框里中输入mstsc后,按回车键确认。
      • 选择开始 > 附件 > 远程桌面连接
    2. 填写待远程登录的Windows实例信息,然后单击连接

      登录成功,表示该问题已解决。


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