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使用百度智能云服务器BCC建站教程-Windows激活相关配置

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使用百度智能云服务器BCC建站教程-Windows激活相关配置

Windows激活相关配置

描述

百度智能云的所有镜像均采用登录即自动激活的方法,不需要任何的手动操作。如果登录发现系统是未激活状态, 即激活失败,可以参照Windows激活失败的处理 ,如果您需要进行手动的重新激活, 可以参照文档Windows手动激活系统教程

百度智能云的所有虚拟机操作系统源文件(ISO)均来自微软的批量许可官方网站(Microsoft Volume Licensing Service Center) https://www.microsoft.com/licensing/servicecenter/

配置

KMS客户端密钥配置

由操作系统源文件制作出来的所有镜像均已经安装了KMS客户端密钥,百度智能云的激活服务器仅能支持激活使用KMS客户端密钥的操作系统镜像,如果密钥被手动更改掉,需要更使用如下方式更改回来:

  • 使用管理员权限 打开命令行, 输入 slmgr.vbs /ipk [KMS Client Key]
  • KMS Client Key 是公开的,可以从微软的官方网站获取 : https://technet.microsoft.com/en-us/library/jj612867(v=ws.11).aspx

    注意:

    打开网站时使用英文文档格式,中文文档偏旧,缺失了Windows Server 2016 的描述

客户端的激活服务器配置

客户端上的激活服务器信息会存放在注册表 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SoftwareProtectionPlatform 底下, 默认服务器指向kms.baidubce.com,使用默认的端口1688

其他信息

  • 镜像如果激活失败,间隔120分钟会自动重新激活一次

Windows手动激活系统教程

百度智能云的镜像采用自动激活的方式完成系统的激活,在某些特定情况下,可能会需要手动激活Windows系统,比如创建系统自动激活失败;自定义镜像中,客户对激活服务器进行指定性修改。

以下是手动激活Windows系统的过程

1.打开有管理员权限的命令行

2.在命令行中输入 slmgr.vbs /ckms 清除kms服务器设置

3.在命令行中输入 slmgr.vbs /rearm 重置计算机密钥状态

4.重启虚拟机之后,激活状态应该是如下显示的

5.重新使用管理员权限打开命令行, 输入 slmgr.vbs /skms kms.baidubce.com:1688 命令

6.在命令行输入 slmgr.vbs /ato 命令, 进行激活

注意:

如果激活仍然未成功, 可以参照Windows 激活失败的处理,同时也可以联系售后支持

Windows激活失败的处理

注意:

此文档中的一部分操作需要您对Windows操作系统有一定的了解, 若您有任何疑惑,请先联系客服人员。 在您进行操作之前,建议对系统盘和数据盘创建快照以防止数据丢失

激活失败的原因是多种多样的, 下列总结了一些碰到过的一些激活失败情况

  • 通信失败
  • 时间和时区不同步
  • 客户端密钥错误
  • 第三方软件影响
  • 服务异常

在我们遇到的激活失败中,经常会出现类似这样的提示窗口 ”错误:[错误码] , 在运行Microsoft Windows非核心的计算机上,运行 ”slui.exe 0x2a [错误码]“ 以显示文本“, 这句话的意思是运行的程序发生了激活客户端的错误, 但是没有办法显示字符串, 需要运行命令才能得到可读的错误信息。slui.exe 是Windows 激活客户端,主要是用于许可证激活的,有这个提示的错误可能主要和许可证相关的问题引起的,这种情况下,先打开命令行工具CMD, 输入提示提及的字符串,看看具体错误是什么。例如:

在命令行中输入“slui.exe 0x2a 0xBBA”后, 弹出窗口,显示可读的详细描述

接下来我们详细记录一下碰到的一些激活失败的案例

通信失败

现象

当百度智能云的Windows系统处于未激活状态,并试图激活系统时出错,错误码为0xC004F074

原因

百度智能云Windows的激活是通过KMS服务器来进行的,出现上述错误的原因是Windows和KMS服务器之间的链路不通。KMS服务器在云平台内网,正常情况下,无论Windows是否添加EIP,都是可以联通的。

处理方法

  1. 确认网卡是否被禁用
  2. 确认ping kms.baidubce.com 是否能通、域名 kms.baidubce.com的解析是否正确
  3. 确认是否有软件或设置对端口存在限制

    3.1检查防火墙是否对kms.baidubce.com TCP 1688端口存在限制

    3.2检查IP安全组策略是否对kms.baidubce.com TCP 1688端口存在限制

    3.3检查杀毒软件、安全软件,是否对kms.baidubce.com TCP 1688端口存在限制

  4. 检查路由配置表,打开有管理员权限的CMD,输入 route print 确认是否为内网路由
  5. 确认telnet kms.baidubce.com 是否能通
  6. 若上述步骤均无问题,可以尝试重新激活,在有管理员权限的CMD中,执行如下命令
    6.1 slmgr /skms kms.baidubce.com:1688

    6.2 slmgr /ato

    6.3 更详细的手动激活信息可以查看 Windows 手动激活系统教程

时间和时区不同步

现象

当百度智能云的Windows系统处于未激活状态,并试图激活系统时出错,错误码为0x80072F8F

原因

Windows系统的时间和时区需要和KMS服务器保持一致,时钟的偏差有可能会导致激活失败

处理方法

  1. 在桌面右下方的系统确认是否偏差较大,手动进行时钟及时区的同步
  2. 使用有管理员权限的命令行工具CMD.exe, 输入 "net start W32Timew32tm /resyn" 进行同步之后,重新激活。

客户端密钥错误

现象

Windows显示系统未激活,且错误代码为0xC004F015;或在系统的属性中,激活部分显示"产品ID不可用"

原因

系统显示授权服务许可证未安装,可能是当前系统不被VLK的Server所认可,检测发现系统使用的激活码与VLSC发布的系统激活码不一致。

处理方法

将KMS 客户端密钥重新安装

  1. 从微软的官方网站 https://technet.microsoft.com/en-us/library/jj612867(v=ws.11).aspx  下载KMS客户端密钥 a. 注意:打开网站时使用英文文档格式, 中文文档偏旧,缺失了Windows Server 2016 的描述 b. Windows 2008 R2 Data Center:74YFP-3QFB3-KQT8W-PMXWJ-7M648 c. Windows 2012 R2 Data Center:48HP8-DN98B-MYWDG-T2DCC-8W83P d. Windows 2016 Data Center: CB7KF-BWN84-R7R2Y-793K2-8XDDG
  2. 使用如下两个命令进行密钥安装和重新激活 a. slmgr.vbs /ipk [KMS Client Key] b. slmgr.vbs /ato

第三方软件影响

现象

第三方的杀毒软件或者木马病毒也会影响系统激活。 例如,一个需要使用到的服务被“安全狗软件”停止,从而导致激活失败。由第三方软件引起的错误码是多种多样的,比较常见的是“拒绝访问”, 错误码是0xC0000022

处理方法

第三方软件通常在安全模式下是不会被主动运行的,可以进入安全模式,确认是否能够激活成功。进入安全模式的方法如下:

  1. 使用命令行, 输入"msconfig" 命令,打开"系统配置"界面
  2. 在系统配置窗口 -> 一般 ->启动选择, 选择"诊断启动",点击确认按钮,并重启计算机
  3. 在系统启动时,按 F8, 选择"安全模式", 继续启动系统
  4. 在进入操作系统后, 打开管理员权限的命令行, 输入"slmgr.vbs /ato" 命令进行重新激活

服务异常

现象

Windows激活的过程中,会使用到一些服务程序, 比如Software Protection 服务是使用于进行数字许可证激活和检测的,如果这些服务例程异常可能会导致激活失败,错误码是多种多样的,例如错误码是 0x80070002 - 系统无法找到指定文件

原因

Software Protection服务异常,服务使用的程序sppsvc.exe未启动。

处理方法

  1. 重新启动Software Protection 服务: 右键点击"计算机" -> "管理" -> "服务" -> "Software Protection" ,点击启动
  2. 若Software Protection 服务启动失败, 有可能有以下原因

    • 杀毒软件阻止了服务的运行。 关掉杀毒软件再试试
    • 服务配置异常,需要重新设置注册表项 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\sppsvc

      1. 导出注册表项作为备份backup.reg
      2. 从另一台同样版本的系统里面导出正常的注册表项文件normal.reg。 然后导入当前的操作系统
      3. 如果导入失败,则将备份backup.reg 重新导入回原来的计算机, 再次查找其他原因


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